문제 설명

You are given a date. Your task is to find what the day is on that date.



제한사항

Input Format

A single line of input containing the space separated month, day and year, respectively, in MM DD YYYY format.

Output Format

Output the correct day in capital letters.

Others

  • 2000 $\lt$ year $\lt$ 3000

입출력 예

Sample Input 0

08 05 2015

Sample Output 0

WEDNESDAY

Idea

알고리즘 문제같지는 않고, 내가 풀고있는게, 파이썬 문법문제여서 그런것 같다.
음... 계속 해야되나 고민된다.. 알고리즘 문제를 푸는게 맞는것같은데,,
또 어떻게 보면, 파이썬의 내장함수들에 대해서 아는것도 도움이되니, 잘 모르겠다.




Code

# Enter your code here. Read input from STDIN. Print output to STDOUT
import calendar
# print(calendar.TextCalendar(firstweekday=6).formatyear(2022))
query_date = input()
month, day, year = query_date.split()
# print(month, day, year)
month, day, year = int(month), int(day), int(year)
result = {
    0: "MONDAY",
    1: "TUESDAY",
    2: "WEDNESDAY",
    3: "THURSDAY",
    4: "FRIDAY",
    5: "SATURDAY",
    6: "SUNDAY",
    
}
print(result[calendar.weekday(year, month, day)])

Explain

문제가 calendar의 함수에 다 정의되어있었다!!
그냥 불러다가 쓰면된다.
output만 capital letters로 출력해주었다.



References

댓글남기기